CataBlog and WordPress 3.8 Bugs

I know I'm probably a little late breaking with this news, but the latest version of CataBlog has two rendering bugs in WordPress 3.8. But don't worry too much, none of these bugs are fatal. I will try and fix them soon, but I cannot give a timeline since I'm very busy these days.

Issue 1:
The Multifile Upload Button renders improperly. Although it may seem the button is broken, it is not, simply click the button and select your images. If you do get an error, please double check the selected file's size is within your server's configured limits.

Issue 2:
The Edit CataBlog Item panel renders the description field too low. This is really just an inconvenience, especially for shorter monitors that will have to scroll to accommodate for the extra height.

Both these rendering errors are relatively easy fixes that I will try and patch up and release soon. Thanks again for supporting CataBlog and being apart of its community.

- Zach

About Zach

Computer programmer and designer, the sole employee, proprietor and engineer for illProductions.com. Decided to write "CataBlog" based on some customer's needs for musician catalogs, what you get now is the evolution from that original plugin.
This entry was posted in Bug Fix, Support. Bookmark the permalink.

7 Responses to CataBlog and WordPress 3.8 Bugs

  1. Paul says:

    Hi,
    theres a little Bug in CataBlog.class.php Line 2268. (Version 1.6.4)

    Fixed it : $inline_styles[] = “.catablog-description {margin:0 0 0 {$size1}px !important;}”;

    The semicolon was wrong.
    cheers

    • Zach says:

      Thanks for the heads up, I didn’t see this until after releasing 1.6.5 tonight, I’ll try and get to fixing this soon, maybe with the next small release, which will have interface tweaks to match CataBlog with the new WordPress admin interface.

  2. Lynn says:

    Hi,

    I am unableb to edit the catablog items. If i click on ‘edit’ it opens a new window where i should be able to edit. But it just seems to be frozen and i can’t do anything. Is this one of the bugs?

    • Zach says:

      Can you please try deactivating all other plugins and switching your theme to one of the standard WordPress themes. You may be experiencing an incompatibility. If that doesn’t fix it, I am curious what browser and operating system you are using. Thanks.

  3. Melanie says:

    Thanks for these updates. I am having a little issue when uploading. If I upload 20 images, 5 or so will show up with a little broken page icon. I’ve tried resizing the images but still no luck. Any advice? Thanks!

    • Zach says:

      Hmmm…its difficult to say exactly why this is happening, are all your images coming from the same source? Is it possible that the 5 or so our of a different format or corrupted in some way? Do the same 5 files keep failing?

  4. Justin says:

    Zach,
    Newbie here. I know almost nothing about coding. I’m trying to:

    1) On my page, shorten the description with only an excerpt
    2) When I open the Lightbox feature for it to provide the full description.

    I’ve read in other spots on this site to use the %EXCERPT% token to do this, but I’m really not sure where to even put this. I tried adding it in the default, single, and archive templates, but I don’t really even know where in the template to add it. When I save it and refresh my page, it doesn’t seem to really do anything. Please HELP!!!

Leave a Reply

Your email address will not be published. Required fields are marked *

Please wrap any HTML markup or code with the pre-formatted tag: <pre> </pre>